My subwoofer smells when I put it too loud...

Discussion in 'Technology Talk & Help' started by Enkari!, Feb 4, 2012.

Thread Status:
Not open for further replies.
  1. Enkari!

    Enkari!

    70
    13
    4
    Well I've had my Logitech Z623's since like September now and since I got them, the sub would give off a sort of rubbery smell when I turn up my volume past half way.

    Anyone reckon it's just because it's kinda fairly new and I haven't like 'worn them in'? Or maybe is it that it shouldn't smell like that?
     
    Posted Feb 4, 2012
    #1
  2. hm... overheating.
     
    Posted Feb 4, 2012
    #2
  3. Enkari!

    Enkari!

    70
    13
    4
    Yeah that's one thing you'd think, but I doubt it's that :/ It's a weird smell.
     
    Posted Feb 4, 2012
    #3
  4. Certain things smell really strange when they are new out of the box, but being months old I'd say that is very strange. If it were overheating it wouldnt last very long and you'd know. But hey! I'll take it off you hands for free! :p <3
     
    Posted Feb 4, 2012
    #4
  5. Its ye girl, shes been on it TROLOLOL.
     
    Posted Feb 6, 2012
    #5
  6. Kieran

    Kieran

    1,432
    2,056
    20
    I have no clue what this could be, but ill give it a shot.

    What you described (rubber smell, past half way) sounds like when the sub was constructed, they may have misplayed something or misaligned something and as it moves faster the friction is causing it to produce the smell. My suggestion would be to contact Logitech and see if they can provide you a replacement.

    Just remember, don't try to open the sub as it may void your warranty.
     
    Posted Feb 7, 2012
    #6
Thread Status:
Not open for further replies.